I just tried 2.5.2. It's different from 2.5.3 - there's no effect on 2.5.2 at all.
Not sure if it makes a difference - I'm using java 1.6.0_31 16bit on 32bit Win7

On Fri, Sep 21, 2012 at 8:27 AM, Chris Clark <Chris.Clark@actian.com> wrote:
I just tried:

1. Jython 2.2.1 (well my patched version)
2. jython2.5.2
3. jython2.5.3b1

They all work fine, can you (as a diagnostic test) go back a version?

Chris



On Friday 2012-09-21 08:25 (-0700), jlist9 <jlist9@gmail.com> wrote:
Just tried both modifying the registry file and specifying the option in the command line
(not at the same time) and it didn't help. I did observe a difference - the REPL no longer
prints the "..." when I hit Enter. Actually it doesn't print anything. It does go to the next
line. Anything else I can try?

On Thu, Sep 20, 2012 at 10:40 AM, Chris Clark <Chris.Clark@actian.com <mailto:Chris.Clark@actian.com>> wrote:

    Try the workaround in that thread/issue and see if that works ;-)



    On Thursday 2012-09-20 10:39 (-0700), jlist9 <jlist9@gmail.com
    <mailto:jlist9@gmail.com>> wrote:

        It's hard to say. In my example, an array works fine but
        dictionary does not.
        Feels more like a parsing problem in REPL. If I put the same
        code in a source file,
        Jython executes the file just fine. So it's only an REPL issue
        so far.

        On Wed, Sep 19, 2012 at 11:11 PM, YAMANO Yuji
        <Yamano_Yuji@ogis-ri.co.jp <mailto:Yamano_Yuji@ogis-ri.co.jp>
        <mailto:Yamano_Yuji@ogis-ri.co.jp

        <mailto:Yamano_Yuji@ogis-ri.co.jp>>> wrote:

            Same problem?

        http://sourceforge.net/mailarchive/forum.php?thread_name=8D9F2261912EF945B5C982C6FE073BD804B4D26F36%40MAILSJ3.global.cadence.com&forum_name=jython-users

            On Wed, 19 Sep 2012 22:01:06 -0700, jlist9
        <jlist9@gmail.com <mailto:jlist9@gmail.com>
            <mailto:jlist9@gmail.com <mailto:jlist9@gmail.com>>> wrote:

            > I am having this strange problem in REPL. I can type a
        list and
            it's fine.
            > If I
            > type a dictionary in the REPL, it keeps printing out the
        "..."
            lines as if
            > it's
            > still waiting for more input. To make sure, I
        reinstalled Jython
            2.5.3 and
            > still
            > has the problem. Any idea why this is happening? I'm
        using 32bit
            1.6 JRE on
            > 64bit Windows 7. Not sure if this is a problem.
            >
            > Jython 2.5.3 (2.5:c56500f08d34+, Aug 13 2012, 14:48:36)
            > [Java HotSpot(TM) Client VM (Sun Microsystems Inc.)] on
        java1.6.0_31
            > Type "help", "copyright", "credits" or "license" for more
            information.
            >>>> [1, 2, 3]
            > [1, 2, 3]
            >>>> {'a':1}
            > ...
            > ...
            > ...

            --
            YAMANO Yuji
            OGIS-RI




        ------------------------------------------------------------------------------
        Everyone hates slow websites. So do we.
        Make your web apps faster with AppDynamics
        Download AppDynamics Lite for free today:
        http://ad.doubleclick.net/clk;258768047;13503038;j?
        http://info.appdynamics.com/FreeJavaPerformanceDownload.html


        _______________________________________________
        Jython-users mailing list
        Jython-users@lists.sourceforge.net
        <mailto:Jython-users@lists.sourceforge.net>
        https://lists.sourceforge.net/lists/listinfo/jython-users