Hi Alan,

Thank you for the reply. I actually used the sample app in this page (so 
no framework involved): http://opensource.xhaus.com/projects/modjy/wiki/ModjyGoogleAppEngine 
The download page is http://downloads.xhaus.com/modjy_webapp_google_appengine/ 

I didn't modify anything except adding this line in appengine-web.xml, which seems
to be required by the new version of the GAE SDK: (it'd be a good idea to add it
to the download zip)
<threadsafe>true</threadsafe>

I'm not too surprised that I got an exception about java.io.FileOutputStream because
I think I'm running the regular version of Jython. It isn't a problem when running on
GAE in the cloud probably because the error is probably silently ignored by the engine.

When running with dev_appserver.cmd, I get 404 error in browser. I looked but
didn't find jetty logs in the appengine-java-sdk-1.6.5 directory. Any idea where
else I should check?

Thanks,
Jack

On Sat, May 12, 2012 at 6:32 AM, Alan Kennedy <jython-dev@xhaus.com> wrote:
[jlist9]
> The app deployed fine on GAE. However, when I run it locally with the
> dev_appserver.cmd,
> It starts but prints out an error saying java.io.FileOutputStream is a
> restricted class.
> But the server still starts and opens a port. When accessing the
> http://localhost:8080/

Google AppEngine does not permit file I/O, so it is not surprising
that java.io.FileOutputStream is being reported as a restricted class.

However, modjy is definitely not attempting to write to any files. So either

1. Some other part of jython is attempting to write files to the file
system. Have you disabled the package cache?

2. Some other code is trying to write to a file. Perhaps some logging
system is trying to write to a file?

[jlist9]
> URL, I get a 404 NOT_FOUND error. Is this a known issue? According to the
> second
> link above, the local server should also work.

I think this is a different and unrelated error.

What is generating the "404 not found"? It's not modjy.

Are you using a framework? Django? Have you got it configured
correctly? What do the framework-specific logs say?

Have you looked in the container logs, i.e. the jetty logs for  the
appengine dev server?

Alan.