Hi!  I've found some strange behavior.   I try using setuptools to install cmd2 which depends on pyparsing-1.5.2.  Somehow, when using setuptools under jython, the package tries to install the python3 version instead of the python 2.5 version.   I am running jython2.5.  I can get it to work by downloading the source and changing the setup.py file, but this is not ideal.  Has anyone else experienced similar problems?


I am running windows xp-32 bit.  We noticed similar behavior trying to install this on MacOS, so I don't think it's platform specific.

Thanks,
William