This was just me being dumb.  I was running a version of Jython from SVN HEAD between 2.5.1 and 2.5.2b1.
The particular version I had still had JNA embedded into Jython which was causing me grief when I included my own JNA jar files.
I've since upgraded to the 2.5.2b2 release which only has jffi/jaffl and my problems have gone away.
This is what I get for running SVN head and not regularly updating.  :)

From: [] On Behalf Of Jim Baker
Sent: Tuesday, September 28, 2010 1:49 PM
To: Ng, Victor
Subject: Re: [Jython-dev] JNA version?

There's a commented out rule including JNA back when we were using it for some early ctypes work. But I don't see any other reference. Maybe there's some other conflict because we bundle jffi?

On Tue, Sep 28, 2010 at 8:16 AM, Ng, Victor <> wrote:
I've been having problems invoking some parts of the Windows C API via JNA - the problem seems to be conflicting versions of JNA in my classpath - which version of JNA does Jython include?  I'm not sure how to read the ant build.xml file to determine which version of JNA is included in the jython.jar file.

Start uncovering the many advantages of virtual appliances
and start using them to simplify application deployment and
accelerate your shift to cloud computing.
Jython-dev mailing list