Hi Guys,
 
I'm trying to build a new build of jython on java 1.5.0 Beta 1.
Seems the build is working correctly and i use Python 2.2.3
to refer to when building.
 
But when i try to run a module i created i get the next errors.
 
Invoking C:\tn5250j\scripts\GB320.py
Traceback (innermost last):
  File "sre_compile.py", line 15, in ?
AssertionError: SRE module mismatch
Traceback (innermost last):
  File "sre.py", line 17, in ?
  File "C:\Jython-2.1\lib\sre_compile.py", line 17, in ?
AssertionError: SRE module mismatch
Traceback (innermost last):
  File "re.py", line 7, in ?
  File "C:\Jython-2.1\lib\sre.py", line 208, in ?
AttributeError: module 'sre_compile' has no attribute 'compile'
Traceback (innermost last):
  File "javaos.py", line 322, in ?
  File "javaos.py", line 309, in _getOsType
  File "C:\Jython-2.1\lib\sre.py", line 132, in match
NameError: _compile
 
Yeah, i placed the new build over the old one, so copied
everything form CVS\Jython\build to the C:\jython-2.1 dir.
 
I have readed that jythonc does not supports python 2.2
features, so does this mean i have to use python 2.1 to compile ?
i just want jython running on 1.5.0 that's all, so for me python 2.1
is okay too, at least if that fixes the problem :-)
 
So any ideas how to fix this ?
 
Best Regards,
 
Patrick
 
Sysop/Java-programmer Stafa Holland BV
Administrator/Programmer Memoranda-project (SourceForge)
Programmer TN5250J-project (SourceForge)
Programmer DBPirate-project (Java.net)