Hello kent,
 
        Thanks for ur answer. I will try with Python 2.1.
 
Thanks & Reagrds
Prakash.A
 
Kent Wrote:
 
Jython 2.1 implements Python 2.1. The yield keyword is not supported.

Kent

Prakash A wrote:
> Hello All,

>         I am using jython2.1 and also Python 2.3.3. But when i run
> jythonc, i have got an error saying error importing site. Full details
> of the error is given below.

>         # ./jythonc
>         *sys-package-mgr*: processing modified jar,
> '/home/pra/products/jython/jython/jython.jar'
> error importing site
>         Traceback (innermost last):
>           File "/home/pra/products/jython/jython/Lib/site.py", line 69, in ?
>           File "/home/pra/products/jython/jython/Lib/site.py", line 63,
> in makepath
>           File "/home/pra/products/jython/jython/Lib/javaos.py", line
> 29, in ?
>           File "/usr/local/lib/python2.3/UserDict.py", line 86
>                             yield k
>                                    ^
>          SyntaxError: invalid syntax
>          #

>         I saw some mails regarding Jython 2.1 with Python 2.3, saying
> some of the functionalities are not working. But i am not able to
> conclude whether Jython 2.1 supports Python 2.3.3 or not. Which version
> of Python i have to use. Now Python 2.4.1 is released whether i can use
> that one. Please help me in this regards.


> Thanks & Reagrds
> Prakash.A
>