Hello,
I have sent this message twice and have as yet received no reply.  But I need to update the message with new information, the applets that I compiled and were working after hitting the "Refresh" button no longer work.  I recompiled them to try and get them working they still  refused to operate.  Any tips, pointers or help would be greatly appreciated.

I am having some problems with "Jython" and I am hoping that you can help me
to solve them. 

I have written a small Jython Applet using your demonstration code as the
basis for the code and I have run into a problem.  The code I used is pretty
straight forward:

from java import awt, applet

class MyApp(applet.Applet):

    y=10

    def paint(self, g):
        g.setColor(awt.Color.red)
        g.fillRect(5,5,210,80)
        g.setFont(awt.Font('Arial', 0, 15))
        g.setColor(awt.Color.black)
        g.drawString('G Day', 10, 20)

The code compiled with no problem using the line:

jythonc --deep -- core --jar demo1.jar MyApp.py

I then entered the HTML code following in my webpage

<applet code="MyApp"
    archive="demo1.jar"
    width="100"
    height="100">
</applet>

When I run the code nothing happens, all that I receive is an empty grey box
on the screen, it has no text in the box.  Being somewhat familiar with Java
Applets I immediately knew something was up.  So I looked for the status
bar.  The message in the status bar is as follows: "MyApp class can't be
instantiated", I have never seen this error message before.  After that
happened I hit the refresh button by accident, and then the text 'G Day'
appeared in the Applet.  After that I tried it with the example code in the
/demo/example directory on the HelloApplet example and the same thing
occurred, it only displayed after hitting the Refresh button.  It is the
only example that worked.

So my question is this, what am I doing wrong?  Why is the text not being
displayed until after I hit the refresh button on the browser.  I know I
have overlooked something simple but I don't know what it is.

Any help is greatly appreciated.

Thankyou and regards,
Sláinte (Irish for cheers).
-----------------------------------------------
Vaughan Egan   ---   celtic@allstate.net.au
-----------------------------------------------