Dictionary wrong version ?

Help
Anonymous
2003-05-18
2003-05-18

  • Anonymous
    2003-05-18

    Hi ,

    My name is Sorin and I have just started using JWNL. I am usinf Java Visual Cafe and I tried to compile the file Examples.java that comes  with the JWNL.

    The problem is that I get this error :

    Error: invalid file 'net/didion/jwnl/dictionary/Dictionary.class' (wrong version: 46, expected 45)

    Can anyone please help me ...

    Thanks.

     
    • Marin Dimitrov
      Marin Dimitrov
      2003-05-18

      I suspect your Java version is older than the one JWNL was compiled for

      hth,

        Marin

       

    • Anonymous
      2003-05-18

      Thank you for your answer Marin ,

      I suspected that this might be the problem , but unforttunatelly , I changend the version in V. Cafe and I still get the same error .

      Aslo without using the v.cafe when I try to java -jar the jar files present in the ditrribution it is not working.

      How can I run the Examples.java from the command line including the jar files ? (so the compiler can find the classes included in the example)

      Thank you very much

       
      • Marin Dimitrov
        Marin Dimitrov
        2003-05-18

        You can't use java -jar since there is no indication about the main class in the jar's manifest file

        just unzip the jar and use the Examples.class

        and anyways I'm pretty sure your ptoblem is caused by jdk/jre mismatch

        which JRE are you using?

        hth,

            Marin