Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Merge two polygons not working?

2012-02-22
2013-06-05
  • I have just installed OpenJUMP-1.5.1-r2721-PLUS.  Formerly ran 1.4.  Am running Vista Business SP2, 4GB machine.

    When I use Tools > Edit Geometry > Merge Two Polygons, I don't get a merge.  This used to work well in prior versions.

    Any suggestions?

     
  • Hi,

    Works well on my machine. Can you give more details :
    Is your layers editable, your geometries selected.
    Can you copy/paste the WKT of your geometries ?

    Thanks

     
  • Apologies!  I had just installed 1.5.1-r2721-PLUS and the VERY FIRST thing I tried to do was merge two polygons.  I have done thousands of these merges in previous versions of Open Jump over many years, without ever a problem.  This time, it did not work.  I checked everything before going to the support site.  I just couldn't do the merge.

    I should have done more experimentation, because the merge function seems to work fine everywhere else.  It seems I have found some kind of exception, probably because of bad data in one or both objects.  After realizing it was not a problem with Open Jump, I just redrew the combined objects.  I never looked beyond this to find out what was wrong in the data.  However, I have a backup and can go there, but I don't want you to waste time.  I'm now sure it was a "data" problem.  I was working on a polygon shape file.  Everything LOOKED good on screen, but obviously, there must have been something that prevented the merge in the data.

    This new version of Open Jump has so many new features, I'm going to have to spend lots of time learning them all.  Keep up the good work, and thanks for your interest.