Can't open any cluster file, no image

Help
Mikhail
2008-10-13
2013-05-15
  • Mikhail
    Mikhail
    2008-10-13

    When I used 1.1.1 version all was fine. After I installed 1.1.3 version I can't open any cluster file, incluse examples from the site (spellman.cdt etc.). Open button works but after selecting a file and opening it the screen is empty. Versions 1.1.2 and 1.1.1 behave the same now.

    I have all the latest updates, Java SE v6 upd7, 2Gb memory. What can be wrong? Thank you all!

     
    • Alok Saldanha
      Alok Saldanha
      2008-10-15

      Hello,

      I am not sure what's going on, but I have two ideas

      1) Your XML configuration file might have gotten corrupted. Try deleting it - that will just reset you to defaults. On linux, it should be in

      $HOME/.javaTreeViewXmlrc

      2) If that fails, I am a bit stumped. If you run it from the command line, do you get any useful error messages?

      3) If not, what exactly do you mean by empty?

      Good Luck!
      Alok

       
    • Mikhail
      Mikhail
      2008-10-15

      Hello, Alok,

         Thank you for your answer. I read lots of other help topics but still can't solve it. I use WinXP, fully up to date. I uninstalled all Java patches, updates etc. and installed  jdk-6u7-windows-i586-p.exe, SDK and JSE v6u7. I install TreeView via setup.exe, all settings default. It starts without errors, just reporting registered plugins. When I open any cluster file, nothing happened. In console window there are error messages, but I can't figure out how to deal with them. I tried to add in .bat file "java -cp TreeView.jar:lib/nanoxml-2.2.2.jar LinkedView" as first line but it didn't help. Do you have any suggestions? Thank you!

      Exception in thread "AWT-EventQueue-0" java.lang.NullPointerException
              at edu.stanford.genetics.treeview.model.KnnModelLoader.<init>(Unknown So
      urce)
              at edu.stanford.genetics.treeview.model.KnnModel.loadNew(Unknown Source)

              at edu.stanford.genetics.treeview.LinkedViewFrame.loadKnnModel(Unknown S
      ource)
              at edu.stanford.genetics.treeview.LinkedViewFrame.loadFileSet(Unknown So
      urce)
              at edu.stanford.genetics.treeview.TreeViewFrame$FileMenuListener$1.run(U
      nknown Source)
              at java.awt.event.InvocationEvent.dispatch(Unknown Source)
              at java.awt.EventQueue.dispatchEvent(Unknown Source)
              at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
              at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
              at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
              at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
              at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
              at java.awt.EventDispatchThread.run(Unknown Source)

       
    • Alok Saldanha
      Alok Saldanha
      2008-10-15

      Ahh, based on the error message, I think this is the same as "bug" 1400682. You have two options:

      1) Select "Linked" or "Classic" from the style pulldown in the loading screen.
      2) Don't name files with _A or _G.

      For details on the issue, see:
      http://jtreeview.sourceforge.net/docs/FAQ.html#q001

      The earlier bug report is here:
      https://sourceforge.net/tracker/?func=detail&atid=573298&aid=1400682&group_id=84593

      Let me know if this helps,
      Alok

       
    • Mikhail
      Mikhail
      2008-10-16

      Yes, it did help! Exactly those two advices.

      If I try to open K-means clustering file with style "Kmeans" again, nothing works. But it does with style "Linked" or "Classic".

      Hope it's temporary. Thank you for your help and for TreeView - it is useful for many!