Capture plugin

2007-02-20
2013-04-11
  • I installed the capture plugin in jta26, if I run it locally (java -jar jta26.jar -config blah.conf) it will come up and seems to work ok, I get the Capture item on the menu bar and I can start and stop the logging. 

    If I run it from the browser, however (IE and Firefox), I'm missing the menu item and the java console comes up with some funky errors about "Netscape security model no longer supported, please mgrate to the latest Java 2 security model instead.".  This happens if I run it from the web browser on the server or if I do it from a client machine.

    I have signed the jar file already so it is certified, and the copy and paste features are working.  I'm not sure whats going on or if this error is the cause of the problem or not.  Any suggestions?  I'm running Java 1.5.0_08-b03.

    Thanks for any assistance,

    -Shaun

     
    • This is some ancient code that throws this exception. If your applet is signed it should work anyway.
      With missing you say no menu is there or just the capture does not appear?

      Arte.

       
    • Thanks for the quick reply!

      The menu appears, though it doesn't have the Capture menu item listed.  I just get 'File', 'Edit', and 'Help'.  If I run it from the command line, I get these as well as 'Terminal' (i think?) and 'Capture'.  The capture does work, I can start it logging and it puts it to the log window.

      I don't see anything in the console that suggests it is having an error other than the message I listed above.  I see that it is loading the capture plugin (it is listed).  I have placed capture plugin at the end of the list of plugins, just before terminal.  I'm assuming this location works as it does work locally.

      I've tried it from the local linux machine running Firefox 2, as well as my Windows machine with IE7, IE6, and Firefox 2.  They all get the exact same thing.  Is there some way I have to configure the Apache server that I'm not doing perhaps?

      Thanks again,

      -Shaun

       
    • No suggestions out there? :)

      -Shaun

       
      • Well, the Capture plugin itself does not throw that error. Check in the Web browsers java log that everything is loaded correctly. It looks much more that the applet.conf or similar could not be loaded.

         
    • Hi, I have the same problem with you as well. When i run jta26.jar as applet the 'Capture' and 'Terminal' menu is missing. But if run the jta26.jar as standalone program it works well. Anybody can help?