#4 ClassCastException in the Scene window

head
closed-fixed
5
2014-10-24
2004-07-27
Joachim Backhaus
No

A ClassCastException occurs when you open a new Scene
window and import SysEx to it.

Steps to reproduce:
-------------------

Preconditions:
- Make sure you have a valid SysEx file that can be
imported
- Start JSynthLib with Debug Level 2 to get full debug
messages

1. Open a new Scene window
2. Import the SysEx file to the Scene window using the
"Import" funcionality

Actual result:
-------------

An empty row is created and a ClassCastExeption occurs
on the command line.

Expected result:
---------------

A new Patch with the content of the imported file
should be created and shown.

Discussion

    • status: open --> closed
     
    • status: closed --> closed-fixed
     
  • Logged In: YES
    user_id=299446

    The problem was the ArrayList of SceneListModel that was
    directly accessed in SceneFrame.

    Instead of a Scene, a Patch was added there.

    This is fixed now.

     
    • assigned_to: nobody --> jbackhaus