#3 JDK 1.4 compatibility

closed
nobody
None
5
2007-07-03
2007-07-02
Marcelo Liberato
No

I see that there are two distributions, one for jdk1.3+ and another for jdk1.5+.

However, with this patch, json-lib (HEAD grabbed from CVS) could be built on jdk1.4 (all testcases passed). There were some minor dependencies on jdk1.5 such as String.contains(String), Long.valueOf(long) and things like that.

I don't see any reasons to depend on 1.5.

Cheers,
Marcelo

Discussion

  • Patch for jdk 1.4

     
    Attachments
  • aalmiray
    aalmiray
    2007-07-03

    Logged In: YES
    user_id=1192026
    Originator: NO

    Thanks Marcelo, I have applied the patch

     
  • aalmiray
    aalmiray
    2007-07-03

    • status: open --> closed
     
  • aalmiray
    aalmiray
    2007-07-03

    Logged In: YES
    user_id=1192026
    Originator: NO

    PATCHED