JCE Requirement for using JSCH

Rita Rege
2011-06-08
2013-05-28
  • Rita Rege
    Rita Rege
    2011-06-08

    I would soon be using JSCH in my project and had a couple of questions in that context. Please see below:

    I will be using Java 1.4 for my Application (Java project) which would use the JSCH library to transmit files to our sftp server. The linux machine that would host my application would also have Java 1.4. (specifically j2sdk1.4.2_12) Later next year we plan to upgrade to Java 1.6

    - It mentions in the forums and on the website that we need JCE in order to run JSCH. Is there a way to find out or confirm if Java 1.4 version comes with JCE that would work for JSCH… or do I need to worry about it?

    - I believe JCE needs to be present on the Client machine (machine where my program runs to transmit files to our sftp server). Please confirm that this is the correct understanding and Is there anything I need to check for on the server machine?

    Thanks in advance!!