Which ATL version?

Help
martinalex
2013-09-18
2013-09-18
  • martinalex
    martinalex
    2013-09-18

    I tried to compile JPEGView with VS 2010 Express and VS 2011 Pro, but failed.
    Both had problems with ATL.
    WTL was ok.

    For Express I have used ATL sources from MS "Windows Driver Kit". This had ATL version 7. Compile was ok, but link failed. The ATL lib from the same "Windows Driver Kit" didn't fit to the source, atlsd.lib

    MainDlg.obj : error LNK2001: Unresolved external symbol ""void __stdcall ATL::AtlWinModuleAddCreateWndData(struct ATL::_ATL_WIN_MODULE70 ,struct ATL::_AtlCreateWndData ,void *)"

    For Pro I have used ATLMFC which is part of the Pro install, but some atl*.h files were missing.

    Which ATL version is required for JPEGView?

    Martin