wish to run Jose under SableVM 1.11.3

ead0002
2005-08-17
2013-04-24
  • ead0002
    ead0002
    2005-08-17

    Peter,

    Hello. How can I override Jose java version check:

        Java Runtime Environment 1.4 or later required !
        Your current version is 1.11.3
        Please download Java Runtime Environment from
                http://java.sun.com/j2se/downloads.html
        or download the latest jose release from
                http://sourceforge.net/project/showfiles.php?group_id=60120

    I'd like to be able to try out Jose on my Debian linux system, but I need to keep Sun's JRE off of that system. Instead, I'm using the highly-Sun-JRE-compatible SableVM version 1.11.3:

        % java -version
        SableVM version 1.11.3
        - compile date and time: 2005-04-12 06:26:04 UTC
        - gcc version: 3.3.5 (Debian 1:3.3.5-8)
        - 'real life brokenness' features enabled
        - signal based exception detection
        - copying garbage collection
        - bidirectional object layout
        - inline-threaded interpreter

    Thank you for any pointers to a solution.

    Regards,
    Eric

     
    • Peter Schäfer
      Peter Schäfer
      2005-09-20

      Hello,

      unfortunately, there's currently no way to bypass the version check in jose. I will add that option to the next release.

      In any case, I can't garantuee that jose will run with your JRE. I recommend running jose with a bundled copy of the Sun JRE. It takes about 60 MB of disk space and won't interfere with other installed software.