jose doesn't startup on xubuntu

joselitor
2007-03-18
2013-04-24
  • joselitor
    joselitor
    2007-03-18

    Hi there

    i'm trying to run jose 1.4.4 over a xubuntu distro but the program doesn't run. I've tryed both comands ./jose.sh and java -jar jose.jar.  in both cases appears the jose initial window, but after a few seconds it just dessapair and the jose process is not running any more. my java version is

    $ java -version
    java version "1.5.0_08"
    Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_08-b03)
    Java HotSpot(TM) Client VM (build 1.5.0_08-b03, mixed mode, sharing)

    if i put the verbose mode on i get the a really huge output. here i put just the lines with the word "error":
    [Loaded java.lang.Error from shared objects file]
    [Loaded java.lang.LinkageError from shared objects file]
    [Loaded java.lang.NoClassDefFoundError from shared objects file]
    [Loaded java.lang.VirtualMachineError from shared objects file]
    [Loaded java.lang.OutOfMemoryError from shared objects file]
    [Loaded java.lang.StackOverflowError from shared objects file]
    [Loaded java.lang.IncompatibleClassChangeError from shared objects file]
    [Loaded java.lang.NoSuchMethodError from shared objects file]
    [Loaded java.nio.charset.CodingErrorAction from shared objects file]
    [Loaded sun.awt.X11.XToolkit$XErrorHandler from shared objects file]
    [Loaded sun.awt.X11.XErrorEvent from shared objects file]
    [Loaded java.lang.UnsatisfiedLinkError from shared objects file]
    [Loaded de.jose.BootError from file:/home/cescris/Desktop/jose-144-linux/jose.jar]

    Any idea about what's the problem?

    Thanks in advance

        joselitor

     
    • try  --------->     update-alternative --java  or update-alternative -java
      i don't remember

       
    • joselitor
      joselitor
      2007-04-11

      I did what you suggest and I changed the configuration till i got

      $ sudo update-alternatives --config java

      Hay 2 alternativas que suministran `java'.
        Seleccionar Alternativa
      -----------------------------------------------
      *+        1    /usr/lib/jvm/java-1.5.0-sun/jre/bin/java
                2    /usr/bin/gij-wrapper-4.1

      After this I tried to run jose again but got the same result.

       
    • yo uso ese java el "sun-jdk-1.5.0.11"

      bajalo y instalalo

      tal vez despues eligelo con el commando alternative del post interior

      Con ese java me furula bien y con el Crafty ! Que pasada !

       
    • map
      map
      2007-05-31

      Try preceding the command with "sudo" . If that works, you need to change ownership of the jose files and dirs