Pasting causes very bad indentation

Help
mutluit
2012-01-16
2013-05-02
  • mutluit
    mutluit
    2012-01-16

    Hi,
    I am mostly working on the console (bash window), using joe as a "programmer's editor"  for C/C++ source code editing.
    But when editing a source file and pasting some sourcecode snippet from the clipboard, it though gets pasted,
    but very very badly indented/formatted. Just for this function (ie. pasting) I have to quit joe and use another editor (nano).
    Am I missing a switch or a setting somewhere, or what else is the reason joe can't paste text correctly from the clipboard?
    My platform: joe v3.7, bash on Debian GNU/Linux 7 (wheezy) w/gnome desktop

     
  • Marek Grac
    Marek Grac
    2012-01-19

    Hi,

    I believe that this is due to autoindentation, try to set it off before pasting (ctrl+t; i)