can't paste ` into a JOE window !?

Help
2006-03-08
2013-05-02
  • OpenMacNews
    OpenMacNews
    2006-03-08

    hi all,

    when i try to paste a ` (dunno what it is called ... it's the 'other' character on the tilde key ...) into a joe window, it doesn't paste as intended.

    e.g.,

    if i attempt to copy/paste in:

                PWD=`pwd`

    it instead appears as:

                PWD=PwdM

    with the "P" & "M" underscored.

    it's likely an ascii/escape issue ... but what/where is the setting to allow correct pasting?  is it a joe issue, or a terminal issue?

    (this is driving me nuts ...)

    thx!

    richard

     
    • irieiam
      irieiam
      2006-04-04

      That character is called a backtick and since it's probably (near)impossible for your terminal to correctly translate what you past into it, you get that odd effect.  When possible, I use the ^B ^K ^C to copy code with backticks, rather than using the mouse. Tiny pain, just the same.

       
      • OpenMacNews
        OpenMacNews
        2006-04-04

        hi irieiam,

        your suggestion works for copy-n-paste WITHIN joe@shell. thx.

        but, how might i copy from a desktop app (i'm on a Mac), supposedly via Clipboard, into the joe window in a shell?

        my *only* option is kybd paste, no?

        thx!

        richard

         
    • I think this M corresponds to a \r, save the file and do dos2unix.
      Taht could be a workaround until you find the solution