Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

Mac binary for 3.3 does not run on OS/X 10.8

2013-01-25
2013-12-14
  • Hello,

    I just got an  iMac running the latest version of OS/X 10.8.2 (Mountain Lion).  Went to install my all-time favorite text editor by downloading the "Joe for MacOS X"  (version 3.3) package and found joe would not run.  Got the error "BAD CPU type in executable."

    So I had to build Joe 3.7 from source.  I already had installed Apple's XCODE package, which gives me a compiler, Make and all the other Unix stuff that's missing from OS/X.  I then did:

    ./configure
    export LANG=C
    make
    make install

    The 'export LANG=C' was necessary because 'make' failed when 'sed' produced an 'illegal byte sequence'.  A Google search suggested trying LANG=C, and it worked!

    Joe runs fine now, and I'm a happy camper.  I'm willing to help the developers put together an OS/X 10.8 package if you don't have access to that operating system.  (But keep in mind I'm ignorant about much of programming.)  You can contact me at snarmont@gmail.com

    Thanks for keeping a great text editor alive and well!

    • Steve
     
  • Jeffrey Sun
    Jeffrey Sun
    2013-12-14

    Thanks for the info.

    Was making joe on 10.9 and encounter problem.

    The LANG=C solves the problem.