Hey Hillel,
 
You asked how to get Jin running inside of eclipse.  (Useful for using the debugger.)  I managed to get this working.  Here's what I did.
 
First, I set the following project settings:
Second, I run the ant build script, which creates the Jin/build directory.  This is necessary as it puts all the resource sets that Jin needs into the proper directories.
 
Third, I go to the Run menu and select Debug.  And in the Debug config window that pops up, I set the following settings:
Lastly, I hit the "Debug" button, and off she goes.  Once you've got all the settings configured, in the future, it should start up without any further configuration needed.
 
Doug
 
 
In reply to:
Hi all,
I use JIN for a while, and I thought it might be nice to try and help
with JIN development.
I am very new to open source development (CVS and stuff), and my java
knowledge is also lacking, so try and bare with me ;-).
I downloaded the jin branch from CVS, and tried running jin by going to
the directory jin/src/free/jin and typing :
java JinMain
that resulted in : "Exception in thread "main"
java.lang.NoClassDefFoundError: JinMain"

I thus have two questions:
1. how should I run JIN from the cvs sources?
2. I would really like to integrate the project with Eclipse (V3.0). I
actually managed to connect to the CVS through eclipse, and downloaded
the sources, but I was unable to run the project from within eclipse.
this is probably due to the same problem I didn"t manage to run it
through the command line. So if anyone managed to run the project in
Eclipse, with or without CVS integration, I would also love to hear some
suggestions on that.

OS : Mandrake Linux 10.0
Java : JRE 1.4.2_04
Eclipse V3.0

btw, complements to Sasha and all other developers for the great software.

Thanks,
Hillel.