"Thomas Preud'homme" <robotux@celest.fr> wrote on 08/25/2011 02:43:19 PM:


> > > 2/ About dependencies
> > >
> > > a) Jikes RVM build system expect exact version match to build. Is this
> >
> > exact
> >
> > > match in the versions really necessary or would a >= version be ok? If
> >
> > yes,
> >
> > > I'll push a patch on my machine and will come back to you with a link to
> >
> > it.
> >
> >
> > Not sure.  May depend on the package.
>
> Mainly I was thinking about ecj (version 3.5.1 in Debian),
> checkstyle (version 5.4 in Debian) and asm (version 3.2 in Debian).



I don't think we have reason to think they won't work :)  I guess give it a try, and if there are version problems maybe we can upgrade Jikes RVM to work with the newer versions.  ecj in particular is getting really badly out of date at this point.  

--dave