Sounds fine.  No need to be backward compatible on spelling mistakes.  This should have been fixed a long time ago.

--dave