I get this error trying to run jikes on 64bit fedora 12 ./libjavaio.so: ./libjavaio.so: wrong ELF class: ELFCLASS64

Any quick fixes?