#1698 Can't get ctagsinterface working stable in jedit 5

closed
nobody
None
5
2013-02-24
2013-02-19
Anonymous
No

i have to say, ctags has been really flaky recently.. The add project to tag index and create lucene index buttons often break with one of the following stack traces (among many)... The only way to find things wrong is in the the activity log. A user action should be responded with a visible error if it fails.

12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: Exception in thread "AWT-EventQueue-0"
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: java.lang.NoSuchFieldError: LUCENE_34
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at gatchan.jedit.lucene.AnalyzerFactory.<clinit>(AnalyzerFactory.java:41)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at gatchan.jedit.lucene.NewIndexDialog.<init>(NewIndexDialog.java:96)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at gatchan.jedit.lucene.LucenePlugin.getIndexForProject(LucenePlugin.java:217)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at gatchan.jedit.lucene.IndexProjectAction.actionPerformed(IndexProjectAction.java:59)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2018)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2341)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:402)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at javax.swing.AbstractButton.doClick(AbstractButton.java:376)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:833)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:877)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.Component.processMouseEvent(Component.java:6505)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at javax.swing.JComponent.processMouseEvent(JComponent.java:3312)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.Component.processEvent(Component.java:6270)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.Container.processEvent(Container.java:2229)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.Component.dispatchEventImpl(Component.java:4861)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.Container.dispatchEventImpl(Container.java:2287)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.Component.dispatchEvent(Component.java:4687)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4832)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4492)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4422)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.Container.dispatchEventImpl(Container.java:2273)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.Window.dispatchEventImpl(Window.java:2719)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.Component.dispatchEvent(Component.java:4687)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:729)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventQueue.access$200(EventQueue.java:103)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventQueue$3.run(EventQueue.java:688)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventQueue$3.run(EventQueue.java:686)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.security.AccessController.doPrivileged(Native Method)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:87)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventQueue$4.run(EventQueue.java:702)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventQueue$4.run(EventQueue.java:700)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.security.AccessController.doPrivileged(Native Method)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventQueue.dispatchEvent(EventQueue.java:699)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:244)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:163)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:151)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:147)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:139)
12:23:27 PM [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventDispatchThread.run(EventDispatchThread.java:97)

Discussion

  • Alan Ezust
    Alan Ezust
    2013-02-19

    • summary: Can't get ctags working stable in jedit 5 --> Can't get ctagsinterface working stable in jedit 5
     
  • Alan Ezust
    Alan Ezust
    2013-02-19

    Go to plugin manager, click on "remove orphan" and check that there are no old lucene jars in your jars directory.

     

  • Anonymous
    2013-02-24

    I flushed my config completely... sorta works.. sorta closed..

     

  • Anonymous
    2013-02-24

    • status: open --> closed