W dniu 2012-05-26 12:40, kerik-sf@... pisze:
Eric, did you think about jedit checking version dependencies? This
"-jedit-4.5" may make jedit confused. And more likely make plugin
writers confused: what version should I specify when depending on xml
From: Eric Le Lay <kerik-sf@us...> - 2012-05-26 13:18:37
I didn't see your mail before committing the other branch, and
releasing. Lets clear something at first: 2.8.2-jedit-4.5.0 was a typo,
I meant 2.8.3-jedit-4.5.0 from the start and corrected it before
The release of 2 versions follows a discussion on XMLPlugin 2.8.3
It's compatible with the current released version (4.5) but contains
code for the unreleased trunk 5.0.
XMLPlugin says it requires jEdit 4.5, but really requires jEdit trunk
To solve this I released 2 branches of the plugin (with the obvious
Now, "XMLPlugin-2.8.3-jedit-5.0" > "XMLPlugin-2.8.3-jedit-4.5" so
people running trunk will see the version for trunk, people with the
version for 4.5 will be able to upgrade to the version for trunk if
they upgrade to trunk (or when 5.0 is released).
A plugin should depend
on XMLPlugin-2.8.3-jedit-4.5, since it's always a dependency on "version
X or later".
I hope it's clear.
Le Sat, 26 May 2012 13:10:20 +0200,
Jarek Czekalski <jarekczek@...> a écrit :
> W dniu 2012-05-26 12:40, kerik-sf@... pisze:
> > -plugin.xml.XmlPlugin.version=2.8.2
> > +plugin.xml.XmlPlugin.version=2.8.2-jedit-4.5
> Eric, did you think about jedit checking version dependencies? This
> "-jedit-4.5" may make jedit confused. And more likely make plugin
> writers confused: what version should I specify when depending on xml
> plugin 2.8.2?