#3843 Russian localization breaks Search dialog

severe bug
closed-fixed
Alan Ezust
5
2014-01-04
2013-11-12
tokarenko
No

Dear Sir/Madam,

The search dialog window doesn't show up after upgrade from 5.0.99.0 to 5.1.99.0. Same holds true for 5.2.1.0. Same holds true for complete reinstallation. Downgrade resolves the issue.

Executing environment:
- OS: Windows 7 Enterprise
- OS Version: 6.1.7601 Service Pack 1 Build 7601
- Java: 1.7.0_45
- jEdit modules: QuickNotepad (5.0); TextTools (1.15)

I would be grateful if you could fix this.

Discussion

1 2 > >> (Page 1 of 2)
  • Alan Ezust
    Alan Ezust
    2013-11-12

    • status: open --> pending
     
  • Alan Ezust
    Alan Ezust
    2013-11-12

    Which search action are you invoking? Search in directory? Or "Find..." or what?
    Is this related to your keyboard shortcuts changing to something else?
    I need steps to reproduce this.

     
  • tokarenko
    tokarenko
    2013-11-12

    • status: pending --> open
     
  • tokarenko
    tokarenko
    2013-11-12

    Tried both "Find ..." menu item and CTRL+F

     
  • Alan Ezust
    Alan Ezust
    2013-11-12

    • status: open --> pending-works-for-me
     
  • Alan Ezust
    Alan Ezust
    2013-11-12

    tested with windows 7 professional. Unable to reproduce your issue with metal, nimbus, windows standard or windows classic look and feel. Can you reproduce this when running jEdit.exe with -noplugins or -nosettings?
    It works for me.

     
  • tokarenko
    tokarenko
    2013-11-13

    • status: pending-works-for-me --> open-works-for-me
     
  • tokarenko
    tokarenko
    2013-11-13

    Neither -noplugins nor -nosettings option works for me. But downgrade to 5.0.99.0 resolves the issue. I'm using windows classic theme. Can you suggest some other way to diagnose?

     
  • tokarenko
    tokarenko
    2013-11-25

    Tried fresh install on my home PC. Bug persists.
    Differences in operating environment:
    OS: Windows 7 Home Premium x64

     
  • Alan Ezust
    Alan Ezust
    2013-11-25

    you are saying with jedit -nosettings -noplugins, you are still unable to see the search dialog?
    And you also have this issue with the latest daily build? That is so strange.
    Because when I try that, I see the dialog centered nicely on top of the view.
    still unable to reproduce.

     
1 2 > >> (Page 1 of 2)