#3775 FSB roots:/ node (win xp) NPE (lots of network drives)

severe bug
open
nobody
5
2013-10-07
2013-01-03
J-M Malmedy
No

I'm using jEdit 5.0.0 on Windows XP SP3.

In the file browser (or file opening window), when I select the root node, "loading" is displayed but the file list is never refreshed.

The activity logs contains the following error report:

18:14:50 [AWT-EventQueue-0] [error] AWT-EventQueue-0: Exception in thread "AWT-EventQueue-0"
18:14:50 [AWT-EventQueue-0] [error] AWT-EventQueue-0: java.lang.NullPointerException
18:14:50 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.util.regex.Matcher.getTextLength(Unknown Source)
18:14:50 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.util.regex.Matcher.reset(Unknown Source)
18:14:50 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.util.regex.Matcher.(Unknown Source)
18:14:50 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.util.regex.Pattern.matcher(Unknown Source)
18:14:50 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at org.gjt.sp.jedit.io.GlobVFSFileFilter.accept(GlobVFSFileFilter.java:65)
18:14:50 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at org.gjt.sp.jedit.io.GlobVFSFileFilter.accept(GlobVFSFileFilter.java:54)
18:14:50 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at org.gjt.sp.jedit.browser.VFSBrowser.directoryLoaded(VFSBrowser.java:1380)
18:14:50 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at org.gjt.sp.jedit.browser.BrowserView$2.run(BrowserView.java:189)
18:14:50 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.event.InvocationEvent.dispatch(Unknown Source)
18:14:50 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
18:14:50 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventQueue.access$000(Unknown Source)
18:14:50 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventQueue$1.run(Unknown Source)
18:14:50 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventQueue$1.run(Unknown Source)
18:14:50 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.security.AccessController.doPrivileged(Native Method)
18:14:50 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.security.AccessControlContext$1.doIntersectionPrivilege(Unknown Source)
18:14:50 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventQueue.dispatchEvent(Unknown Source)
18:14:50 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
18:14:50 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
18:14:50 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
18:14:50 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
18:14:50 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
18:14:50 [AWT-EventQueue-0] [error] AWT-EventQueue-0: at java.awt.EventDispatchThread.run(Unknown Source)

There is a thread in the forum about this problem:
http://community.jedit.org/?q=node/view/37802

Discussion

<< < 1 2 3 (Page 3 of 3)
  • Alan Ezust
    Alan Ezust
    2013-07-04

    If you put disk in the CD drive, does it still happen?
    Do any of the network drives have an empty label?

     
  • J-M Malmedy
    J-M Malmedy
    2013-07-05

    I still have the problem when there is a CD in the drive. All drives have a label.

     
  • Just for information, I still have the problem with the new jEdit 5.1.

     
  • J-M Malmedy
    J-M Malmedy
    2013-08-01

    Just for information, I still have the problem with the new jEdit 5.1.

     
  • Alan Ezust
    Alan Ezust
    2013-10-07

    • labels: 102674 --> Windows Specific
     
<< < 1 2 3 (Page 3 of 3)