Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#3112 BufferTabs + Mac OSX L&F = empty textareas

closed-out-of-date
nobody
None
5
2012-07-30
2008-06-18
Slava Pestov
No

Sometimes when I close a bunch of buffers, I get 'phantom' tabs in BufferTabs, selecting which removes the text area and leaves a gray box. See http://factorcode.org/slava/broken-buffertabs.png

Discussion

1 2 > >> (Page 1 of 2)
  • Logged In: YES
    user_id=285591
    Originator: NO

    Hi, did you update and recompiled the bufferTabs trunk ? There were changes to be compatible with the bufferSet api

     
    • status: open --> closed-works-for-me
     
  • Logged In: YES
    user_id=914258
    Originator: NO

    Still broken in 4.3pre15

     
  • Alan Ezust
    Alan Ezust
    2008-08-11

    Logged In: YES
    user_id=935841
    Originator: NO

    The trunk of BufferTabs contains some important updates. I will release it today.

     
  • Logged In: YES
    user_id=914258
    Originator: NO

    BufferTabs 1.1.0 does not fix this. The problem is likely in the OS X-specific look & feel code, as I have so far been unable to reproduce the bug when using Metal L & F.

     
  • Alan Ezust
    Alan Ezust
    2008-08-18

    • summary: BufferTabs broken --> BufferTabs + Mac OSX L&F = empty textareas
    • status: closed-works-for-me --> open-works-for-me
     
  • Alan Ezust
    Alan Ezust
    2008-08-18

    Logged In: YES
    user_id=935841
    Originator: NO

    ok reopening and updating the subject.

     
  • Alan Ezust
    Alan Ezust
    2011-11-14

    • status: open-works-for-me --> open
     
  • Evan Wright
    Evan Wright
    2011-11-17

    I've never encountered this problem. Perhaps it was a JVM bug that's now been fixed?

     
  • Alan Ezust
    Alan Ezust
    2012-06-09

    • status: open --> pending
     
1 2 > >> (Page 1 of 2)