#3079 Regular Expression Matching Broken in 4.3 Pre13+

normal bug
closed-duplicate
8
2008-05-29
2008-05-07
Ken Turner
No

As far as I can see, something weird has happened to RE matches from about 4.3 Pre 13 onwards. I'm currently using 4.3 Pre 14 on Windows XP with JDK 1.6.0_02.

Suppose I create a document containing just "Hello", select "Regular Expression", and try some searches.

The following searches work: H.*o, H.*, .*o, e+

The following searches fail to match anything: .*, e*, l*

It looks like "*" isn't working properly in some circumstances.

I'm pretty sure this kind of thing used to work, notably things like (.*)

Discussion

  • Ken Turner
    Ken Turner
    2008-05-07

    Logged In: YES
    user_id=741814
    Originator: YES

    Also, ^ works but $ doesn't.

     
  • Alan Ezust
    Alan Ezust
    2008-05-27

    • priority: 5 --> 8
     
  • Alan Ezust
    Alan Ezust
    2008-05-28

    • assigned_to: nobody --> k_satoda
     
  • Alan Ezust
    Alan Ezust
    2008-05-28

    Logged In: YES
    user_id=935841
    Originator: NO

    kazutoshi, is it ok if I assign this to you?

     
  • Logged In: YES
    user_id=1483238
    Originator: NO

    This looks a duplicate of the bug #1671312.
    https://sourceforge.net/support/tracker.php?aid=1671312
    According to #1671312, the problem happens since jEdit 4.3pre9.

     
    • status: open --> closed-duplicate
     
  • Ken Turner
    Ken Turner
    2008-05-29

    Logged In: YES
    user_id=741814
    Originator: YES

    Yes, #1671312 looks to be in the same area. I guess that the * (possibly empty match) and the $ (which now seems to need \n as well) might make this the same issue. I hope the current situation is something that will be improved. The current interpretation of REs isn't very pleasant. Thanks!