#3055 Special NumPad Keys not bindable

closed-fixed
7
2008-09-12
2008-04-07
John Potelle
No

4.3pre13 under WinXP, Jave 1.6.0_03 (might also be in 4.3pre12, I didn't test that version).

Previously (4.3pre7) I had bound NumPad keys ADD, SUBTRACT, MULTIPLY, etc. to functions different from their main keyboard equivalents. This works fine up through 4.3pre11. But in 4.3pre13 these NumPad keys are acting as if I pressed +,-,*,etc. on the main keyboard. Perhaps this is related to the fixing of SF.net Bug #1166530 by Kazutoshi Satoda??

Discussion

  • No, #1166530 is not relevant. It was the issue on parsing "X+x" syntax.

    The fix in r11222 for another bug #1788460, which was released with
    4.3pre13, looks causing this.
    https://sourceforge.net/support/tracker.php?aid=1788460

    But sorry, I don't know the way to fix both problems for now.

     
  • John Potelle
    John Potelle
    2008-09-11

    This is a regression, then. I find it very hard to believe the keyboard handling classes in JAVA can't distinguish between keys on the main keyboard v.s. the number pad. Basically it means I can't use any version beyond pre12 since Kjell Eiirk Andersen emailed me that "This worked fine on pre12 too !"

     
  • John Potelle
    John Potelle
    2008-09-11

    • priority: 5 --> 7
     
  • Fixed in r13655.

     
    • assigned_to: nobody --> k_satoda
    • status: open --> closed-fixed
     
  • kandersen
    kandersen
    2008-09-18

    Sad that this issue is closed, I assign numpad keys ADD, SUBTRACT, MULTIPLY as shortcuts to macros and would really appreciate a fix !

    Best regards,
    Kjell Eirik Andersen

     
  • For the case that my last comment was too brief, now I rephrese it.

    I closed this item because I made the fix for this problem in svn
    revision 13655. Thus the numpad keys (ADD, SUBTRACT, etc) will become
    bindable again with the next release of jEdit.