Problem beim Download von Gekko

Help
2012-10-08
2012-12-06
  • Hallo Zusammen
    Ich habe heute wieder mal meinen Gekko angeschlossen, weil mein Sohn damit ein paar Tauchgaenge gemacht hat, aber leider konnte ich die Tauchgaenge nicht herunterladen. Es erscheint immer nur ein lehres Fenster ohne Tauchgaenge auch wenn die Checkbox zum Downloaden aller TGs aktiviert ist. Das downloaden von meinem Vytec funktioniert problemlos.
    Gibts dazu irgend einen Tip? Fehlersuche?
    Ich verwende JDivelog 2.17 Auf Win7 64Bit.
    Gruesse Herbert

     
  • André Schenk
    André Schenk
    2012-10-09

    Hallo Herbert,

    kannst Du bitte mal das in 2.17 mitgelieferte jdivelog.jar durch dieses ersetzen und JDiveLog von der Kommandozeile starten? Ich habe da ein paar Debugausgaben eingebaut. Die müßtest Du mir dann mal schicken.

    Danke!

    Tschüß André

     
  • Hallo Andre

    Hier ist der Output:
    Okt 09, 2012 9:03:16 PM net.sf.jdivelog.comm.CommUtil initialize
    Information:    INFO: Initializing JavaCommAPI Comm Ports
    WARNING: javax.comm-Classes not found! JavaCommAPI support disabled!
       INFO: Initializing RXTX-2.1 Comm Ports
       INFO: RXTX Port found: COM3
       INFO: RXTX Port found: COM5
       INFO: CommUtil initialization finished.

    read
    read
    read
    read
    read
    read
    read
    read
    read
    read
    read
    read
    read
    read
    read
    read
    read
    read
    read
    read
    read
    read
    read
    read
    read
    read
    read
    read
    read
    read
    read
    read
    read

    Danke fuer die Hilfe!!!

    Gruesse Herbert

     
  • André Schenk
    André Schenk
    2012-10-12

    Hallo Herbert,

    sorry, ich bin ein wenig ratlos. Ich habe an die o.g. Stelle ein neues jdivelog.jar abgelegt, das nun alle Lese- und Schreiboperationen ausgibt. Würdest Du mir davon bitte einen Mitschnitt schicken?

    Verstehe ich Dich richtig, daß am gleichen PC mit dem gleichen JDiveLog das Auslesen eines Vytec funktioniert?

    Tschüß André

     
  • Hallo Andre

    Unten ist das neue log.

    Es ist richtig, am gleichen PC mit dem Gleichen jdibvelog funktioniert es.

    Was ich festgestellt habe: Wenn ich versuche vom Gekko runter zu laden, erscheint der Dialog ohne Tauchgaenge schon bevor die Kommunikation abgeschlossen ist, das LED auf dem Serial interface blinkt dann och ein bischen weiter. Koennte es ev. ein Timing problem sein? Es kann sein, dass ich das letzte mal beim Auslesen vom Gekko noch einen aelteren, etwas langsameren PC hatte.

    Gruesse Herbert

    D:\apps\JDiveLog\bin>"%JAVA_HOME%\bin\java" -Dskindir="D:\apps\JDiveLog\skins" -jar jdivelog.jar
    Okt 12, 2012 8:34:46 PM net.sf.jdivelog.comm.CommUtil initialize
    Information:    INFO: Initializing JavaCommAPI Comm Ports
    WARNING: javax.comm-Classes not found! JavaCommAPI support disabled!
       INFO: Initializing RXTX-2.1 Comm Ports
       INFO: RXTX Port found: COM3
       INFO: RXTX Port found: COM5
       INFO: CommUtil initialization finished.

    write
    read (0)
    read (0)
    read (0)
    read (0)
    read (0)
    read (0)
    read (0)
    read (0)
    read (0)
    read (0)
    read (0)
    read (0)
    read (0)
    read (0)
    write
    read (0)
    read (0)
    read (0)
    read (0)
    read (0)
    read (0)
    read (0)
    read (0)
    read (0)
    read (0)
    read (0)
    read (0)
    read (0)
    read (0)
    write
    read (1)
    read (3)
    read (1)
    read (1)
    write
    read (1)

     
  • Hallo Andre

    Ich habe ein download mit dem SuuntoXML tool von hier versucht: http://home.gci.net/~liquidimagephoto/Suunto.htm. Dort erhalte ich bad checksum Fehler. Ich habe jetzt mal alles auf dem Gecko geloescht. Mal sehen obs das naechste mal funktioniert…

    Gruesse Herbert

     
  • André Schenk
    André Schenk
    2012-10-14

    Hallo Herbert,

    ich kann mal versuchen zu interpretieren, was ich sehe:

    write  = "AT\n"

    Hier wird nur erwartet, daß das gleiche wieder zurückkommt (Test auf local echo).

    read (0)

    Kommt  also nicht zurück. Das scheint aber an sich Problem zu sein.

    write  = lies Inhalt von Speicherplatz 36 (Computermodell)

    read (1) read (3) read (1) read (1) = 13 (Gekko)

    Er spricht also mit Dir!

    write  = starte Download der Tauchgangsprofile
    read (1) Das scheint nun völlig falsch zu sein. Es müßte 08 + count + n Bytes an Daten zurückzukommen (siehe hier.

    Ich weiß da leider nicht weiter. Ich gehe davon aus, daß der Download vom Gekko bei anderen funktioniert und es bei Dir tatsächlich irgendein Timingproblem ist.

    Hast Du noch einen anderen PC, mit dem Du das ausprobieren könntest?

    Hat Dein Rechner eine echte RS232-Schnittstelle ode benutzt Du einen USB-Konverter?

    Tschüß André

     
  • André Schenk
    André Schenk
    2012-10-14

    Hallo Herbert,

    Korrektur: Kommt also nicht zurück. Das scheint aber an sich kein Problem zu sein.

    Tschüß André