#4 Fix for jde-import-kill-extra-imports not working

closed-accepted
nobody
None
5
2009-07-29
2007-12-31
Paul Kinnucan
No

Carlos Konstanski [ckonstanski@pippiandcarlos.com]:

Try the patch located at:

http://article.gmane.org/gmane.emacs.jdee/4974/match=jde+import+kill+extra+imports

At Mon, 29 Oct 2007 18:00:24 +0800,
James Mao wrote:
>
> Hi,
>
> I'm using the GNU emacs 22.1 with jde 2.3.5.1 (and cedet-1.0pre4), and
> I found that the jde-import-kill-extra-imports not working, It gave me
> "Wrong type argument: arrayp, 20"
>
> Debugger entered--Lisp error: (wrong-type-argument arrayp 20)
> jde-import-kill-extra-imports(nil)
> call-interactively(jde-import-kill-extra-imports)
> execute-extended-command(nil)
> call-interactively(execute-extended-command)
>

Discussion

  • Was going to report this bug but, fortunately, had the sense to scour the trackers first. Why isn't the patch in the branch or trunk though?

     
  • Len Trigg
    Len Trigg
    2009-07-29

    Applied on 2.4.0 branch.

     
  • Len Trigg
    Len Trigg
    2009-07-29

    • status: open --> closed-accepted