[ Including 'devel' -- details in the appended mail below ]

Is this a bug? Or am I missing something?

However,
 the 'sourcepath' argument is missing when JDEE launches jdb

Also,
 note the output from the jdb 'use' command:
cd /Users/livin/foo
/System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/bin/jdb -launch -classpath /Users/livin/foo/class:/Users/livin/baz my.jde.JDB1

Set uncaught java.lang.Throwable
Set deferred uncaught java.lang.Throwable
Initializing jdb ...
VM Started: No frames on the current call stack

main[1] step
Exception occurred: java.lang.ClassNotFoundException (uncaught)"thread=main", java.lang.ClassLoader.loadClass(), line=346 bci=416

main[1] 
main[1] use
/Users/livin/foo/class:/Users/livin/baz
main[1] 

I had expected this 'command' to be executed/generated [i.e. with sourcepath included]:
/System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/bin/jdb -launch -classpath /Users/livin/foo/class -sourcepath /Users/livin/foo/src:/Users/livin/bar/src my.jde.JDB



Livin Stephen Sharma




On Mar 08, 2010, at 19:41:10 , Livin Stephen Sharma wrote:

JDEE 2.4.0.1
Emacs 23.1.50.1

 JDEE seems to not be reading/using the 'jde-sourcepath' variable for JDB ['jde-jdb']



Here is a sample of the content/output from the debug buffer:
cd /Users/livin/foo
/System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home/bin/jdb -launch -classpath /Users/livin/foo/class my.jde.JDB

Set uncaught java.lang.Throwable
Set deferred uncaught java.lang.Throwable
Initializing jdb ...
VM Started: No frames on the current call stack

main[1] 

This is despite the variable being defined in prj.el:
 '(jde-sourcepath (quote ("/Users/livin/foo/src" "/Users/livin/baz/src")))


Livin Stephen Sharma