#7 JDEE does not compile on OS X due to setnu.el errors

closed-out-of-date
nobody
None
5
2009-05-14
2008-02-19
Anonymous
No

When I cd into my ~/elisp/jde/lisp directory and type "make" I get a bunch of warnings and then this error:

In end of data:
setnu.el:449:1:Warning: the following functions are not known to be defined:
set-extent-begin-glyph, remove-specifier, set-specifier
Wrote /Users/adhamh/elisp/jde/lisp/setnu.elc
Wrote /Users/adhamh/elisp/jde/lisp/which.elc
make: *** [all] Error 1

sw_vers
ProductName: Mac OS X
ProductVersion: 10.5.2
BuildVersion: 9C31

emacs --version
GNU Emacs 22.1.1

I have tired both setnu.el 1.0.5 and setnu.el 1.0.6 and they both give the same error.

I have attached the full output of the make command.

Discussion

  • make log

     
    Attachments
  • adhamh findlay
    adhamh findlay
    2008-02-19

    Logged In: YES
    user_id=817505
    Originator: NO

    This was submitted by me.

     
  • Espen Wiborg
    Espen Wiborg
    2008-05-30

    Logged In: YES
    user_id=1707163
    Originator: NO

    The problem is actually efc.el, not setnu.el.

    I've just sent a patch to jdee-devel that makes efc.el compile again; could you try that?

    --
    Espen

     
  • Paul Landes
    Paul Landes
    2009-05-14

    • status: open --> closed-out-of-date
     
  • Paul Landes
    Paul Landes
    2009-05-14

    We now have a completely revamped Ant based build. I wasn't using OSX when building this for the 2.3.5.x version, so if it persists, reopen it.