upload a zip file when SVN is configured

Help
Aaron
2010-06-21
2012-12-15
  • Aaron
    Aaron
    2010-06-21

    I'm running into trouble when I want to upload  a zip file even though I have SVN configured.  I choose that I will upload a tarball/zip, and that seems to go okay.  The problem arises after the diffs are created and I try to select files. 
    There are none to select.  I search for * and I get nothing, I search for *.c and I get nothing.
    Also of note, is when I go back to the summary tab, the SVN repository is shown, but grayed out.  I would expect it to say something like tarball/zip.

    Aaron

     
  • Aaron
    Aaron
    2010-06-21

    okay, so I underestimated this issue.  I can't get any files, regardless of if I pull them from SVN or not.

     
  • Aaron
    Aaron
    2010-06-21

    Well things seem to have returned to status 1, SVN works, but still not files.

     
  • John Dickson
    John Dickson
    2010-06-22

    Hi alager

    There's nothing I'm aware of that causes the problem you describe.  So, could you provide some more information to help me reproduce this issue?  Here's what I'd like:

    - The exact steps you took up to the time the issue occurred - everything you entered, clicked etc., plus the effect of each of those actions
    - What JCR did (exactly), versus what you expected it to do.  A screenshot might be useful
    - The JCR log
    - If possible, a couple of small source code zip files which show the issue.

    Thanks in advance ………………………. JD

     
  • Aaron
    Aaron
    2010-06-22

    I'm using winXP and firefox.  The file is a standard zip file.
    1)log in
    2)create project (screen shot)
    3)view summary page (screen shot, notice the repository change)
    4)create file set, select check box for "No original file set "
    5)click select under the "modified file set"
    6) click "create new file set" in the pop up.
    7) name the file set "1.3.057.028" then browse and upload zip file.
    8)click select in the action column
    9)back in the file set screen, click submit.
    10) current status says: generating diffs.  Then says to select files.
    11)click files tab.
    12)click "add files"
    13)in search field put an asterisk: *
    14)click search. (screen shot)
    15) get message that no files are found.(screen shot)

    There are two things in the log file that indicate a problem (to me), but I don't know what would cause it.
    One is that the unzip command returns a warning code, the other is that diff stats added 0 files:
    08:22:17,156 INFO  selectfileset  User: aaronl: Uploading new file set
    08:22:17,157 DEBUG tarvcs  Saving uploaded file to /opt/jcr-0.7.2.1/tmp/upload-77915
    08:22:20,173 INFO  tarvcs  Saving and unzipping file /opt/jcr-0.7.2.1/tmp/upload-77915 to directory /opt/jcr-0.7.2.1/filesets/
    2
    08:22:20,173 DEBUG common  About to execute command: (cd /opt/jcr-0.7.2.1/filesets/2 && nice unzip /opt/jcr-0.7.2.1/tmp/upload
    -77915 > /dev/null 2>&1 )
    08:22:20,218 WARNI common  Command [(cd /opt/jcr-0.7.2.1/filesets/2 && nice unzip /opt/jcr-0.7.2.1/tmp/upload-77915 > /dev/nul
    l 2>&1 )] returned: 32512
    08:22:20,220 INFO  tarvcs  Saving and unzipping of file /opt/jcr-0.7.2.1/tmp/upload-77915 completed
    08:22:20,222 INFO  selectfileset  User: aaronl: Created new file set FileSet 2
    08:22:20,242 DEBUG middleware  Response time:  3.288s, URL: /projectadmin/selectfileset/upload
    08:22:20,304 INFO  selectfileset  User: aaronl: Selecting file sets for project 1
    08:22:20,313 DEBUG middleware  Response time:  0.061s, URL: /projectadmin/selectfileset
    08:23:12,739 DEBUG projectstats  Starting project stats cache refresh
    08:23:12,740 DEBUG projectstats  Refreshing comments stats in project stats cache
    08:23:12,744 DEBUG projectstats  Comments stats refresh completed
    08:23:12,745 DEBUG projectstats  Project stats cache refresh completed
    08:23:55,794 INFO  filesets  User: aaronl: Updating file sets for Project 1
    08:23:55,823 INFO  filesets  User: aaronl: File set(s) updated, deleting attached project files for Project 1
    08:23:56,339 INFO  diff  Triggering diff generation for Project 1
    08:23:56,340 DEBUG diff  De-queued ProjectDiffRequest, for project 1
    08:23:56,351 INFO  diff  Starting diff and Java index processes for Project 1
    08:23:56,351 INFO  diff  Starting diff script for project directory: /opt/jcr-0.7.2.1/projects/lkj-1277219824  original: None
    modified: /opt/jcr-0.7.2.1/filesets/2
    08:23:56,352 INFO  diff  Diff stats - added: 0 files for project directory: /opt/jcr-0.7.2.1/projects/lkj-1277219824
    08:23:56,353 INFO  diff  Diff script completed for project directory: /opt/jcr-0.7.2.1/projects/lkj-1277219824
    08:23:56,353 INFO  diff  Starting java index script for project directory: /opt/jcr-0.7.2.1/projects/lkj-1277219824  modified:
    /opt/jcr-0.7.2.1/filesets/2
    08:23:56,353 INFO  diff  Java index script completed for project directory: /opt/jcr-0.7.2.1/projects/lkj-1277219824  modified
    : /opt/jcr-0.7.2.1/filesets/2
    08:23:56,410 DEBUG middleware  Response time:  0.637s, URL: /projectadmin/filesets/update/1
    08:23:56,471 DEBUG middleware  Response time:  0.056s, URL: /projectadmin/filesets/index/1
    08:23:56,494 INFO  summary  User: aaronl: Displaying project summary for Project 1
    08:23:56,508 DEBUG middleware  Response time:  0.033s, URL: /projectadmin/summary/index/1
    08:23:57,058 DEBUG common  Flushing all cached file lines for Project 1
    08:23:57,059 DEBUG diff  Updated status after diff generation for Project 1
    08:23:57,060 INFO  diff  Completed diff and Java index processes for Project 1
    08:23:57,060 DEBUG diff  Completed handling of ProjectDiffRequest, for project 1

     
  • Aaron
    Aaron
    2010-06-22

     
  • Aaron
    Aaron
    2010-06-22

    solved it.  I didn't have unzip installed on this server, whereas I did have it on my test setup.  It's working now.

     
  • John Dickson
    John Dickson
    2010-06-22

    Hi

    Great timing - I was just writing an email to explain that :)

    You should have seen a message during installation/setup that tarballs/zipfiles wouldn't work, but obviously the Create Project page has a bug in still allowing you to select that option.  Sorry about that.

    By the way, which 'unzip' are you using?  I wouldn't mind adding that to the documentation.

    Anyway, I hope things go more smoothly now.

    Cheers …………………………………. JD

     
  • Aaron
    Aaron
    2010-06-22

    I'm on ubuntu server, so I just used aptitude to search for unzip, saw it and installed it. 
    $ unzip -v
    UnZip 5.52 of 28 February 2005, by Ubuntu. Original by Info-ZIP.