JCR installation on latest Ubuntu

Help
MMN
2011-12-13
2012-12-15
  • MMN
    MMN
    2011-12-13

    Hello,

    I have installed JCR 0.7.2 following the installation steps on Ubuntu 11.10 (oneiric). I have installed all support packages mysql, python-mysqldb, easy_install etc. The installation of JCR was also successful. However when I try to create the .ini file I am getting
    mmn@mmn-hp-workstation-xw4100:~/jcr-0.7.2.1$ paster make-config jcr jcr.ini
    Distribution already installed:
      jcr 0.7.2.1 from /usr/local/lib/python2.7/dist-packages/jcr-0.7.2.1.egg
    Traceback (most recent call last):
      File "/usr/bin/paster", line 18, in <module>
        command.run()
      File "/usr/lib/python2.7/dist-packages/paste/script/command.py", line 84, in run
        invoke(command, command_name, options, args)
      File "/usr/lib/python2.7/dist-packages/paste/script/command.py", line 123, in invoke
        exit_code = runner.run(args)
      File "/usr/lib/python2.7/dist-packages/paste/script/appinstall.py", line 68, in run
        return super(AbstractInstallCommand, self).run(new_args)
      File "/usr/lib/python2.7/dist-packages/paste/script/command.py", line 218, in run
        result = self.command()
      File "/usr/lib/python2.7/dist-packages/paste/script/appinstall.py", line 295, in command
        self.distro, self.options.ep_group, self.options.ep_name)
      File "/usr/lib/python2.7/dist-packages/paste/script/appinstall.py", line 234, in get_installer
        'paste.app_install', ep_name)
      File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 2245, in load_entry_point
        return ep.load()
      File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 1954, in load
        if require: self.require(env, installer)
      File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 1967, in require
        working_set.resolve(self.dist.requires(self.extras),env,installer))
      File "/usr/lib/python2.7/dist-packages/pkg_resources.py", line 556, in resolve
        raise VersionConflict(dist,req) # XXX put more info here
    pkg_resources.VersionConflict: (SQLAlchemy 0.6.8 (/usr/lib/python2.7/dist-packages), Requirement.parse('SQLAlchemy>=0.4,<=0.4.9'))

    Looks like the SQLAlchemy version is too high. I cannot reduce the SQLAlchemy version as I suspect that would affect the sanity of what I have installed. Can you please help me get around this problem?

     
  • Shinta Smith
    Shinta Smith
    2012-02-22

    I am also having this issue with Ubuntu 11.04. Any updates on how to get around this?

     
  • John Dickson
    John Dickson
    2012-02-23

    Hi folks

    Sorry for missing the previous post - I thought I'd replied.

    As you've worked out, the problem is caused by Ubuntu having a later version of SQLAlchemy installed, which JCR can't deal with.

    The easiest way to deal with this is to use virtualenv.  That will allow you to use JCR's preferred library versions without getting in the way of anything else installed on your system.  For example:

        sudo easy_install virtualenv
        virtualenv virtual-jcr
        cd virtual-jcr
        source bin/activate
        easy_install /path/to/jcr-0.7.2.egg
    

    To run JCR and its config steps, you need to either source bin/activate, or use the python in bin.

    Let me know if you have any problems with this.

    One more thing you should know - I'm not planning to develop or maintain JCR any further, since we're now using Crucible at work.

    Cheers …………………………………….. JD