#225 Replace log4j.jar with version 1.2.1

v2.4 (stable)
closed
Scott M Stark
5
2003-09-09
2002-05-22
Ari Schot
No

The JBoss-2.4.4-src distribution contains five different
obsolete versions of log4j.jar. Please replace them with
version 1.2.1. This requires a minor patch to
jboss/src/main/org/jboss/logging/log4j/
ConsoleAppender.java

Please find attached the following:

- a "find" command showing where the log4j jars
are replaced

- a "diff -c" showing the changes to
ConsoleAppender.java. You need to change
"event.priority" --> "event.level" in two places.

Please also replace the log4j.jars in JBoss 3.x.
This can be done without any code changes.

Download link for log4j-1.2.1.jar:
http://jakarta.apache.org/log4j/jakarta-log4j-1.2.1.tar.gz

Regards,
Ari

Discussion

  • Ari Schot
    Ari Schot
    2002-05-26

    • labels: --> JBossServer
    • milestone: --> v2.4 (stable)
    • assigned_to: nobody --> starksm
     
  • Juha Lindfors
    Juha Lindfors
    2003-09-09

    • status: open --> closed