Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#344 jboss 3.0 a/b cmp entity problem

v3.0 Rabbit Hole
closed-invalid
nobody
JBossCMP (436)
5
2002-02-28
2002-02-27
No

jboss 3.0 alpha
jboss 3.0 beta

No jdbc drivers taken from ../lib/ext/ xxx.jar for
beta, you can forget about this, you should copy them
in whoops ! the .../deploy directory and, as a plus, I
didn't succeeded till now to create a very dummy
entity bean in the alpha version, server crashes when
is calling org.jboss.ejb.plugins.cmp.jdbc.entityExists
( Object pk ) with pk String, Long,etc., it seems that
this method receives a null value. In beta even at
deployment time( I don't succed to call EJBHome.create
() ... as in alpha ) a dummy
" org.jboss.deployment.DeploymentException: Could not
deploy file:/dummyentityejb.jar; - nested throwable
is: javax.management.MBeanException: Exception in
service lifecyle operation: create
at org.jboss.ejb.EJBDeployer.deploy
(EJBDeployer.java:475)"
Regards,

Discussion

  • Dain Sundstrom
    Dain Sundstrom
    2002-02-27

    Logged In: YES
    user_id=251431

    What is the problem you are having?

    Post some useful information.

    Bug report are for bugs, bitching is for the forums and
    user mailing list.

     
  • marc fleury
    marc fleury
    2002-02-27

    • status: open --> open-invalid
     
  • marc fleury
    marc fleury
    2002-02-27

    Logged In: YES
    user_id=174548

    I have closed this report as it is more "bitching" than a
    report. The only thing that I want confirmation on is that
    lib/ext is no longer supported, I am unaware of this so
    double check your stuff and come with a solid report

     
  • Ignacio Coloma
    Ignacio Coloma
    2002-02-27

    Logged In: YES
    user_id=376362

    The only point that I have experienced myself is that
    <classpath archives="
    mm.mysql-2.0.11-bin.jar
    "/>

    Used to need the jar file in lib/ext and now if it is not
    on the deploy dir then you get a warning saying that it
    cannot find it. Not really a problem since the classes are
    found anyway and the DataSource is still deployed.

    I like more the new behaviour because it makes admin
    easier. Now I can admin my application without looking at
    jars in lib/ext.

     
  • Logged In: YES
    user_id=318586

    attached you will find needed info concerning my deployment
    problem for jb3beta

     
  • build and test

     
    Attachments
  • Logged In: YES
    user_id=318586

    updated information concerning my deployment problem in
    jboss 3.0 beta, src, description , screen capture etc.

     
  • Dain Sundstrom
    Dain Sundstrom
    2002-02-28

    • status: open-invalid --> closed-invalid
     
  • Dain Sundstrom
    Dain Sundstrom
    2002-02-28

    Logged In: YES
    user_id=251431

    Open a new bug report with a detailed explination of the
    problem and a small test case which reproduces the
    problem. Don't use arj to compress your code. Use jar or
    tar.