I've started the slow migration towards a more clean separation between
model and GUI framework by doing a major refactoring on classes and
But before that, I tagged the CVS as version 22.214.171.124, just in case
something goes terribly wrong.
The new package naming convention should allow us to start separating the
net model from JHotDraw data structures in a more clean way, leaving
framework-independent classes in separate packages.
Of course, the classes are still the same, or slightly renamed, but with
time, we should properly separate them into model (JHotDraw independent) and
GUI (JHotDraw dependent, that could also be ported to other frameworks).
I also fixed all the bugs you mentioned on previous messages (except that
one about the automatic renaming when pasting).
A new version is already available in the webstart address:
Please let me know your thoughts on this.