File handling error for tagbkup.exe on Window

Anonymous
2010-10-08
2012-12-06

  • Anonymous
    2010-10-08

    I'd like to let you know about an error in the compiled Windows version.

    Typing

        dir /b/s *.mp3 > listfile

    at the Windows cmd prompt (as you suggest when using the -f option on tagbkup.exe) produces a DOS-formatted text file.  But if I try to feed this to tagbkup.exe, it chokes and only restores or backs-up 0 or 1 file.  The reason appears to be that it is expecting a Unix-formatted text file.  If I run dos2unix on the text file first, then feed it to tagbkup.exe, everything works as expected.

    There is a likewise problem when trying to bypass creating a file and piping the directory list directly to tagbkup.exe, i.e.

        dir /b/s *.mp3 | tagbkup.exe -r backupfolder

    So, I suggest you modify the Windows executable so that it expects DOS-formatted text input.

    Also, one other thing: it would be super nice if you make it clear on your website that tagbkup.exe should be run from the command line.  I'm a n00b, and when I heard the tagbkup.sh had been compiled in an executable, I figured I could just run it by double-clicking on it.  Took my 20 minutes to figure out.

    Thanks for this fantastic piece of software.

     

  • Anonymous
    2010-10-08

    By the way, for anyone who doesn't know, you need cygwin (or something similar) to run the command dos2unix.  There's must be a version for the DOS cmd prompt, but I don't know it.  I happened to have cygwin because I tried to run tagbkup.sh on it, with no luck, before moving onto the windows compiled version.

     
  • Thanks for letting me know. I will look into it. I have been using it with the cygwin version so I would not have noticed this.
    The tagbkup.sh should work. That is what I use regularly. Let me know what the problem is with tagbkup.sh under cygwin.

     
  • I have fixed the problem. Try downloading the new version (1.26)