Jalopy Java Source Code Formatter / News: Recent posts

Jalopy 1.5b5 The lowdown

New features.
Automatic recognition (and addition) of java generics for javadoc's. Also generics within a javadoc no longer causes format failures.

The home page (http://jalopy.sf.net) has a new facelift thanks to maven.

Fixes
Parameters wrapping to early Spaces where being counted twice when parameters where being wrapped.
Formatting succeeded then failed see1346698.
No space before the method name (when using Generics) see1346640.
Space after comma doesn't work for Generics see 1343796.
enum formatting munges whitespace see 1339021
Generic in Javadoc causes parser error see 1339008

Posted by S 2005-11-18

Jalopy (1.5b3) Bug fix release

Hi

Thanks to a lot of input we are now on our third beta version of the 1.5 release.

Jalopy is now being built by Maven 1.0.2 (mavaen.apache.org).

Also note all plugins have been reversioned (Starting at 0.1). The new version sequence is based on the <plugin version>-<jalopy-version>

Posted by S 2005-10-26

Jalopy goes to 1.5b1

Jalopy will now understands Java 5 (1.5) syntax.
Along with this change some small formatting improvements and features have been added.

Enjoy...

Posted by S 2005-09-01

Netbeans Plugin Moved to netbeans.org

The Netbeans 4.1 Jalopy plugin has moved to http://contrib.netbeans.org

Posted by Rob Clevenger 2005-03-21

Looking for someone to update the parser to JDK 5.0 (1.5)

If anyone is interested, please let me [rcleveng at users dot sourceforge dot net] know. It'd be nice to get the opensource version of Jalopy to under JDK 5.0 syntax.

Thanks.

Posted by Rob Clevenger 2004-12-10

Jalopy plugin for JDeveloper 10.1.3 Released.

New plugin for JDeveloper 10.1.3 released (it's jalopy-jdeveloper 1.1.5) available for download.

Posted by Rob Clevenger 2004-12-10

Eclipse Plugin 0.2.7 released.

There are only two changes for this release. The first is that version 0.2.7 now works with and requires Eclipse 3.0 and it was built against 3.0M9. Second is that the core Jalopy has been updated to 1.0b11 which is the latest release in CVS.

Posted by Rob Clevenger 2004-06-15