Garbled Bibtex file

Help
2009-10-08
2012-11-09
  • Joe Hernandez
    Joe Hernandez
    2009-10-08

    Hello everyone,

    I am using Linux and JabRef version 2.5

    I have an issue with the .bib file. When I oped it in a text editor each
    character has a preceding ^@ in front of it

    "
    ��^@%^@ ^@T^@h^@i^@s^@ ^@f^@i^@l^@e^@ ^@w^@a^@s^@ ^@c^@r^@e^@a^@t^@e^@d^@
    ^@w^@$
    ^@%^@ ^@E^@n^@c^@o^@d^@i^@n^@g^@:^@ ^@U^@T^@F^@-^@1^@6^@
    ^@
    ^@@^@A^@R^@T^@I^@C^@L^@E^@{^@b^@i^@c^@o^@2^@0^@0^@0^@,^@
    ^@ ^@ ^@a^@u^@t^@h^@o^@r^@ ^@=^@ ^@{^@B^@i^@c^@o^@,^@ ^@J^@.^@ ^@a^@n^@d^@
    ^@Q^$
    ^@ ^@ ^@t^@i^@t^@l^@e^@ ^@=^@ ^@{^@L^@i^@q^@u^@i^@d^@ ^@t^@r^@a^@i^@n^@s^@
    ^@i^$
    ^@ ^@ ^@j^@o^@u^@r^@n^@a^@l^@ ^@=^@ ^@{^@E^@u^@r^@o^@p^@h^@y^@s^@i^@c^@s^@
    ^@L^$
    ^@ ^@ ^@y^@e^@a^@r^@ ^@=^@ ^@{^@2^@0^@0^@0^@}^@,^@
    ^@ ^@ ^@v^@o^@l^@u^@m^@e^@ ^@=^@ ^@{^@5^@1^@}^@,^@
    ^@ ^@ ^@p^@a^@g^@e^@s^@ ^@=^@ ^@{^@5^@4^@6^@-^@-^@5^@5^@0^@}^@,^@
    ^@ ^@ ^@n^@u^@m^@b^@e^@r^@ ^@=^@ ^@{^@5^@}^@,^@

    "

    and when i open it in openoffice it looks like this

    "
    þÿ#%# #T#h#i#s# #f#i#l#e# #w#a#s# #c#r#e#a#t#e#d#
    #w#i#t#h# #J#a#b#R#e#f# #2#.#5#.#
    #%# #E#n#c#o#d#i#n#g#:# #U#T#F#-#1#6#
    #
    #@#A#R#T#I#C#L#E#{#b#i#c#o#2#0#0#0#,#
    # # #a#u#t#h#o#r# #=# #{#B#i#c#o#,# #J#.# #a#n#d#
    #Q#u#\#'#{#e#}#r#\#'#{#e#}#,# #D#.#}#,#
    # # #t#i#t#l#e# #=# #{#L#i#q#u#i#d# #t#r#a#i#n#s#
    #i#n# #a# #t#u#b#e#}#,#
    # # #j#o#u#r#n#a#l# #=# #{#E#u#r#o#p#h#y#s#i#c#s#
    #L#e#t#t#e#r#s#}#,#
    # # #y#e#a#r# #=# #{#2#0#0#0#}#,#
    # # #v#o#l#u#m#e# #=# #{#5#1#}#,#
    # # #p#a#g#e#s# #=# #{#5#4#6#-#-#5#5#0#}#,#
    "

    i am able to find and replace all in openoffice to remove the extra characters
    but I would like to simply copy my .bib into my tex folders and run it without
    editing it.

     
  • What it looks like for me is that your file has been saved in the UTF-16
    character encoding, and your text editor doesn't recognize this. I don't think
    UTF-16 is default for any platforms, so I would advice you to change the
    default encoding in Preferences -> General to ISO8859_1. For the existing
    database you may need to reset the encoding in File -> Database properties
    afterwards, or it will (I think) keep the encoding you are using now.

     
  • Joe Hernandez
    Joe Hernandez
    2009-10-08

    That cleaned up the mess but is there a font that will encode greek characters
    too. When i copy and paste from a clipboard it breaks it after encoding

    Abstract  â€‚A micron-resolution particle image velocimetry
    (micro-PIV) system has been developed to measure instantaneous and ensemble-
    averaged flow fields in micron-scale fluidic devices. The system utilizes an
    epifluorescent microscope, 100–300 nm diameter seed particles, and an
    intensified CCD camera to record high-resolution particle-image fields.
    Velocity vector fields can be measured with spatial resolutions down to
    6.9×6.9×1.5 μm some

     
  • UTF-8 is one encoding that I think will encode all Greek characters.

    It also depends on how you are planning to use the bib file. If you are using
    it for LaTeX/BibTeX, you can also use LaTeX character commands like \alpha,
    \beta etc. I don't remember whether these must be used in math mode or not.