Problem Uploading

Help
mizanation
2005-08-24
2013-02-24
  • mizanation
    mizanation
    2005-08-24

    Hi, I am having just one problem with j-ftp and it's with uploading.

    Specifically, I am unable to upload to a directory, even though I am able to upload the same file to any other directory on the server.  The permissions are set to allow read/write access to everyone (I am on Unix).

    Here's the log output when I try to upload:

    426 Data connection: Broken pipe.
    [24/Aug/2005:14:31:50] info ( 2631): [/piweb] > TYPE I
    [24/Aug/2005:14:31:50] info ( 2631): [/piweb] Cannot list remote directory!
    [24/Aug/2005:14:31:50] info ( 2631): [/piweb] > TYPE I
    [24/Aug/2005:14:31:50] info ( 2631): [/piweb] java.lang.NullPointerException @FtpConnection::upload

    Does anyone know what is going on?

    Also, when I upload using a regular FTP client, I am able to upload fine.

    Please help!

    Thanks,

    mizanation

     
    • mizanation
      mizanation
      2005-08-24

      Never mind.  I fixed the problem by creating a .jftp directory.

      Thanks,

      mizanation

       
    • mizanation
      mizanation
      2005-08-30

      I fixed the original problem by creating a .jftp directory.  Now, I have a new problem!  Now, only parts of my files are being transfered!  When I remove the .jftp directory, it works again, but my first problem is back.

      HELP!

       
    • Jake Kasprzak
      Jake Kasprzak
      2005-09-10

      Hello, and I apologize for taking as long as I did to get back to you.

      Well, if this is happening only when uploading to a certain directory, then it won't be easy for us to test this out. And just to be sure, when it uploads partial files, does this happen when uploading to one directory. If so, could you tell me what, if anything, may be different about this directory? This may be related to upload resuming somehow, and we can continue looking into this. There are other bugfixes and enhancements to the project that need to be made, but we'll see if we can find the time to fix what appears to be some sort of nbug that we have here. And we may have other questions for you as we look into this.

      Thanks,

      J.K.