Can't build IVTQTGUILib (VS2008 - QT4.6.1)

Help
2010-02-15
2013-05-09
  • Hello, I would like to test the examples from the book, however I can't build the IVTQTGUILib.  I am using visual studio 2008  and QT 4.6.1.
    I have followed the instructions from 'Installation-EN.pdf' referred to in a previous post.

    I get the following message when trying to build:

    1>---- Rebuild All started: Project: IVTQTGUILib, Configuration: Debug Win32 ----
    1>Deleting intermediate and output files for project 'IVTQTGUILib', configuration 'Debug|Win32'
    1>Performing Custom Build Step
    1>Das System kann den angegebenen Pfad nicht finden.
    1>Project : error PRJ0019: A tool returned an error code from "Performing Custom Build Step"
    1>Project : warning PRJ0018 : The following environment variables were not found:
    1>$(QTDIR)
    1>Build log was saved at "file://c:\Programme\IVT\win32\IVTLib\Debug-gui\BuildLog.htm"
    1>IVTQTGUILib - 1 error(s), 0 warning(s)
    ========== Rebuild All: 0 succeeded, 1 failed, 0 skipped ==========

    What should I do ?

    Thanks !

     
  • Pedram Azad
    Pedram Azad
    2010-02-19

    Hi,

    it seems that your environment variable QTDIR is not defined. Your qt installation should set that variable automatically usually. Go to System and there add to your environment variables the variable QTDIR and assign as value to path to your Qt directory.

    Also, for compiling the examples provided with the book, it is recommended to use the IVT version that is stated in the installation guide in the appendix.

    Pedram

     
  • Hugo
    Hugo
    2010-02-19

    I added QTDIR to the environment variables (win XP), however I also had to add C:\Qt\4.6.1\include\Qt to the include directories as the compiler did not find several header files (they are located in subdirectories of C:\Qt\4.6.1\include).
    The IVTQTGUILib  then compiled without errors.

    Thank you for your help and for the excellent 'Computer Vision' book !

    Hugo

     
  • Daniel DUMITRU
    Daniel DUMITRU
    2010-04-21

    would you please point me to that "Installation-EN.pdf" file ?
    Search doesn't work that good here.
    REgards,
    Daniel

     
  • Pedram Azad
    Pedram Azad
    2010-05-07

    Hi,

    I finally updated the source code from the book to run with the current version 1.3.8-1 (and upcoming versions) of the IVT. Qt is not required anymore (except for the application from chapter 10).

    The applications from the chapters 6 and 7 require OpenCV 1.0 - all other applications are completely stand-alone now and run without any other additional libraries. In addition to the Microsoft Visual Studio project files, I have also added Makefiles that run with Linux, Mac OS X, etc.

    Please let me know if you experience any problems.

    Pedram