#222 Test failures on non-i386 architectures

release_4.3.x
accepted
None
1
2013-12-01
2013-05-29
Kumar Appaiah
No

Hi.

It turns out that IT++ fails to build on several architectures other than i386 and amd64. Some build logs are:

https://buildd.debian.org/status/fetch.php?pkg=libitpp&arch=hurd-i386&ver=4.3.0-1&stamp=1369787672
https://buildd.debian.org/status/fetch.php?pkg=libitpp&arch=i386&ver=4.3.0-1&stamp=1369788407
https://buildd.debian.org/status/fetch.php?pkg=libitpp&arch=powerpc&ver=4.3.0-1&stamp=1369787623
https://buildd.debian.org/status/fetch.php?pkg=libitpp&arch=s390&ver=4.3.0-1&stamp=1369788761

It used to pass tests on these architectures, so there is some problem. I will investigate this further and report my observations.

Thanks.

Discussion

<< < 1 2 (Page 2 of 2)
  • Bogdan Cristea
    Bogdan Cristea
    2013-08-04

    • status: accepted --> closed
     
  • J B
    J B
    2013-11-01

    Hi,

    I have a problem with the multilateration test failing on x86_64 (but not 386) for openSUSE >= 13.1.
    See build logs here:
    https://build.opensuse.org/package/rawlog/home:lnt-sysadmin:branches:science/libitpp/openSUSE_13.1/x86_64

    The relevant error messages while running the tests are:

    [ 1370s] [----------] 2 tests from Multilateration
    [ 1370s] [ RUN      ] Multilateration.get_pos
    [ 1370s] *** Warning in /home/abuild/rpmbuild/BUILD/itpp-4.3.1/itpp/comm/multilateration.cpp on line 272:
    [ 1370s] cannot update subsets
    [ 1370s] *** Warning in /home/abuild/rpmbuild/BUILD/itpp-4.3.1/itpp/comm/multilateration.cpp on line 1306:
    [ 1370s] error in geo_pos_update_subsets
    [ 1370s] /home/abuild/rpmbuild/BUILD/itpp-4.3.1/gtests/multilateration_test.cpp:223: Failure
    [ 1370s] Value of: multi.get_pos(actual_ms_pos, meas)
    [ 1370s]   Actual: false
    [ 1370s] Expected: true
    

    I think the problem fits this bugreport, but I will open a new one if requested.

     
  • Bogdan Cristea
    Bogdan Cristea
    2013-11-01

    I can confirm this issue with openSUSE 13.1 RC1, but I would wait for the final release before considering fixing this issue (all tests pass on openSUSE 12.3)

     
    • J B
      J B
      2013-11-04

      Okay, I agree. On the other hand, I doubt there will be a lot of changes affecting IT++ from 13.1 RC2 to GM.

      Note: the compiled 'itpp_gtests' binary from a 13.1 system runs without failure on a 12.3 system. Thus, I suspect the update in boost libraries in 13.1 causes the problem.

       
      • Bogdan Cristea
        Bogdan Cristea
        2013-11-04

        IT++ does not depend on boost and AFAIK neither Google test. Different external libraries versions might be the explanation.

         
        Last edit: Bogdan Cristea 2013-11-04
  • Bogdan Cristea
    Bogdan Cristea
    2013-11-01

    • status: closed --> open
     
  • Bogdan Cristea
    Bogdan Cristea
    2013-12-01

    • status: open --> accepted
     
  • Bogdan Cristea
    Bogdan Cristea
    2013-12-01

    this bug is a duplicate of bug #235

     
<< < 1 2 (Page 2 of 2)