Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#33 basic_ios::clear

SNAP_2.0
open
nobody
5
2014-05-04
2010-04-09
Anonymous
No

Whenever I try and load data using ITK SNAP (v1.4 and v2.0) I get the following error. Not sure if it has anything to do with the first warning message about the IRQ's not working correctly when SNAP is first opened up.

[code]
ivan@teletran-2:/usr/local/snap/itksnap-2.0.0-20091117-Linux-i686/bin$ ./itksnap

do_wait: drmWaitVBlank returned -1, IRQs don't seem to be working correctly.
Try adjusting the vblank_mode configuration parameter.
terminate called after throwing an instance of 'std::ios_base::failure'
what(): basic_ios::clear
Aborted
[/code]

Thinking it may have something to do with the compiler I'm using. I'm on Ubuntu 9.10

Below is more info:

ivan@teletran-2:/usr/local/snap/itksnap-2.0.0-20091117-Linux-i686/bin$ aptitude show gcc
Package: gcc
State: installed
Automatically installed: no
Version: 4:4.4.1-1ubuntu2
Priority: optional
Section: devel
Maintainer: Ubuntu Developers ubuntu-devel-discuss@lists.ubuntu.com
Uncompressed Size: 65.5k
Depends: cpp (>= 4:4.4.1-1ubuntu2), gcc-4.4 (>= 4.4.1-1)
Recommends: libc6-dev | libc-dev
Suggests: gcc-multilib, make, manpages-dev, autoconf, automake1.9, libtool,
flex, bison, gdb, gcc-doc
Conflicts: gcc-doc (< 1:2.95.3)
Provides: c-compiler
Description: The GNU C compiler
This is the GNU C compiler, a fairly portable optimizing compiler for C.

This is a dependency package providing the default GNU C compiler.

ivan@teletran-2:/usr/local/snap/itksnap-2.0.0-20091117-Linux-i686/bin$ aptitude show g++
Package: g++
State: installed
Automatically installed: no
Version: 4:4.4.1-1ubuntu2
Priority: optional
Section: devel
Maintainer: Ubuntu Developers ubuntu-devel-discuss@lists.ubuntu.com
Uncompressed Size: 41.0k
Depends: cpp (>= 4:4.4.1-1ubuntu2), gcc (>= 4:4.4.1-1ubuntu2), g++-4.4 (>=
4.4.1-1), gcc-4.4 (>= 4.4.1-1)
Suggests: g++-multilib
Provides: c++-compiler
Description: The GNU C++ compiler
This is the GNU C++ compiler, a fairly portable optimizing compiler for C++.

This is a dependency package providing the default GNU C++ compiler.
[/code]

Discussion