Work at SourceForge, help us to make it a better place! We have an immediate need for a Support Technician in our San Francisco or Denver office.

Close

#249 Make error

iTALC 2
closed-fixed
5
2013-08-26
2013-02-28
Anonymous
No

When I tried to compile the iTALC code, I got the following error:

CMake Error at cmake/modules/FindPAM.cmake:70 (message):
PAM was not found
Call Stack (most recent call first):
CMakeLists.txt:86 (FIND_PACKAGE)

It is clearly visible from this error message that libpam was not installed in my machine. But it was not mentioned in the installation document of this application.

I use debain based GNU/Linux distribution, all I did was installed a package named 'libpam0g-dev". And then cleaned up the temporary build directory and recompiled/Cmaked the application.

I have added a line "-libpam-dev" in to a file called INSTALL. The below given is the git diff after making the changes:
diff --git a/INSTALL b/INSTALL
index 9394ea6..3596f1f 100644
--- a/INSTALL
+++ b/INSTALL
@@ -29,6 +29,7 @@ Requirements:
- libjpeg62-dev/libjpeg-devel
- zlib1g-dev/zlib-devel
- libssl-dev/openssl-devel
+- libpam-dev

Of course GCC/G++ must not be missing...

As I would be extremely happy to do the debian package upgrade of the latest version of iTALC (2.0) as listed in http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=640200, if someone (who did the packing of the older version of iTALC) could guide me do so!?

Thank you :)

Discussion

    • status: open --> closed-fixed
    • assigned_to: Tobias Doerffel
     
  • Thanks for the bug report! Issue has been fixed in commit 99778e595d219afb3c349762e082c90963897625.