I've created a very simple configuration for iscsitarget (i.e., IET):

>Target iqn.2012-11.com.example.san1:sda
> Lun 0 Path=/dev/drbd7,Type=blockio
> Lun 1 Path=/dev/drbd8,Type=blockio
> Lun 2 Path=/dev/drbd9,Type=blockio
> Lun 3 Path=/dev/drbd10,Type=blockio
>Target iqn.2012-11.com.example.san1:sdb
> Lun 0 Path=/dev/drbd107,Type=blockio

However, none of the LUN's appear on the initiator:

>xen1:~ # iscsiadm -m session -P3
>iSCSI Transport Class version 2.0-870
>version 2.0-872.suse
>Target: iqn.2012-11.com.example.san1:sdb
>    Current Portal: 192.168.1.1:3260,1
>    Persistent Portal: 192.168.1.1:3260,1
>        **********
>        Interface:
>        **********
>        Iface Name: default
>        Iface Transport: tcp
>        Iface Initiatorname: iqn.1996-04.de.suse:01:2441bbdc6224
>        Iface IPaddress: 192.168.1.3
>        Iface HWaddress: <empty>
>        Iface Netdev: <empty>
>        SID: 1
>        iSCSI Connection State: LOGGED IN
>        iSCSI Session State: LOGGED_IN
>        Internal iscsid Session State: NO CHANGE
>        *********
>        Timeouts:
>        *********
>        Recovery Timeout: 120
>        Target Reset Timeout: 30
>        LUN Reset Timeout: 30
>        Abort Timeout: 15
>        *****
>        CHAP:
>        *****
>        username: <empty>
>        password: ********
>        username_in: <empty>
>        password_in: ********
>        ************************
>        Negotiated iSCSI params:
>        ************************
>        HeaderDigest: None
>        DataDigest: None
>        MaxRecvDataSegmentLength: 262144
>        MaxXmitDataSegmentLength: 8192
>        FirstBurstLength: 65536
>        MaxBurstLength: 262144
>        ImmediateData: Yes
>        InitialR2T: Yes
>        MaxOutstandingR2T: 1
>        ************************
>        Attached SCSI devices:
>        ************************
>        Host Number: 6    State: running
>Target: iqn.2012-11.com.example.san1:sda
>    Current Portal: 192.168.1.1:3260,1
>    Persistent Portal: 192.168.1.1:3260,1
>        **********
>        Interface:
>        **********
>        Iface Name: default
>        Iface Transport: tcp
>        Iface Initiatorname: iqn.1996-04.de.suse:01:2441bbdc6224
>        Iface IPaddress: 192.168.1.3
>        Iface HWaddress: <empty>
>        Iface Netdev: <empty>
>        SID: 2
>        iSCSI Connection State: LOGGED IN
>        iSCSI Session State: LOGGED_IN
>        Internal iscsid Session State: NO CHANGE
>        *********
>        Timeouts:
>        *********
>        Recovery Timeout: 120
>        Target Reset Timeout: 30
>        LUN Reset Timeout: 30
>        Abort Timeout: 15
>        *****
>        CHAP:
>        *****
>        username: <empty>
>        password: ********
>        username_in: <empty>
>        password_in: ********
>        ************************
>        Negotiated iSCSI params:
>        ************************
>        HeaderDigest: None
>        DataDigest: None
>        MaxRecvDataSegmentLength: 262144
>        MaxXmitDataSegmentLength: 8192
>        FirstBurstLength: 65536
>        MaxBurstLength: 262144
>        ImmediateData: Yes
>        InitialR2T: Yes
>        MaxOutstandingR2T: 1
>        ************************
>        Attached SCSI devices:
>        ************************
>        Host Number: 7    State: running

Why aren't the LUN's visible to the initiator?

Eric P.
Truckee, CA