#3 Support for libtool-1.4

closed-fixed
nobody
None
5
2002-07-31
2001-08-03
Pavel Roskin
No

It is wrong to require autoconf, automake and libtool
on the used machine. You should be using "make
distcheck" to create self-contained distribution files.

But since you are using libtool, here's the fix that
allows using libtool 1.4. I also added versions up to
1.6 - I hope they won't break thing by then. Actually,
it's better to test for features, not for version
numbers, especially in the software that you distrubute
to the users (which is unfortunately the case for
autogen.sh in your build system).

The patch is against 0.9.14, but the problem is not
fixed in CVS yet.

Discussion

  • Pavel Roskin
    Pavel Roskin
    2001-08-03

    Patch to allow using libtool 1.4 and above

     
    Attachments
    • status: open --> closed-fixed
     
  • Logged In: YES
    user_id=124403

    Done in 0.9.15